Application slowdown

Incident Report for Rossum

Resolved

Our engineers identified the issue and resolved it.
Posted Feb 11, 2025 - 10:05 UTC

Investigating

Our application is currently experiencing some slowdown. Our team is already investigating.
Posted Feb 11, 2025 - 09:36 UTC
This incident affected: EU Ireland.