Application slowdown

Incident Report for Rossum

Resolved

Our team has fixed the underlying issue, and the document processing times should be normal. If you are still experiencing long import times, please get in touch with our support team at support@rossum.ai.
Posted Mar 03, 2025 - 16:55 UTC

Investigating

Our application is currently experiencing some slowdown. Our team is already investigating.
Posted Mar 03, 2025 - 15:02 UTC
This incident affected: EU Ireland.