Application slowdown
Incident Report for Rossum
Resolved
This incident has been resolved.
Posted Mar 06, 2023 - 07:21 UTC
Investigating
Our application is currently experiencing some slowdown. Our team is already investigating.
Posted Mar 06, 2023 - 06:47 UTC
This incident affected: EU Ireland.