Application slowdown

Incident Report for Rossum

Resolved

This incident has been resolved.
Posted Mar 03, 2023 - 07:23 UTC

Investigating

Our application is currently experiencing some slowdown. Our team is already investigating.
Posted Mar 03, 2023 - 06:45 UTC
This incident affected: EU Ireland.