Application Slowdown

Incident Report for Rossum

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 20:00 UTC

Investigating

Our application is currently experiencing some slowdown.
Posted Mar 02, 2026 - 17:30 UTC
This incident affected: EU Ireland.