Application slowdown

Incident Report for Rossum

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:46 UTC

Investigating

Our application (legacy extraction pipeline) is currently experiencing some slowdown. Our team is already investigating.
Posted Oct 21, 2025 - 08:31 UTC
This incident affected: US east coast.