Application slowdown & intermittent unavailability

Incident Report for Rossum

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 00:00 UTC

Investigating

Our application is currently experiencing some slowdown and short-lasting outages. Our team is already investigating.
Posted Apr 03, 2026 - 15:53 UTC
This incident affected: US east coast.