Application slowdown
Incident Report for Rossum
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 07:14 UTC
Investigating
Our application is currently experiencing slowdown in document processing status updates in the Elis app. Our teams have been working on mitigating the underlying issue.
Posted Sep 04, 2024 - 06:55 UTC
This incident affected: EU Ireland.