Document processing slowdown

Incident Report for Rossum

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 18:00 UTC

Investigating

Our application is currently experiencing some slowdown in document processing. Our team is already investigating.
Posted Feb 06, 2025 - 17:28 UTC
This incident affected: EU Frankfurt.