Application slowdown

Incident Report for Rossum

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 12:14 UTC

Monitoring

System should be fully functioning back again.
Posted Jan 30, 2026 - 11:51 UTC

Investigating

Our application is currently experiencing some slowdown. Our team is already investigating.
Posted Jan 30, 2026 - 11:34 UTC
This incident affected: EU Ireland.