Application slowdown
Incident Report for Rossum
Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 14:32 UTC
Investigating
Our application is currently experiencing some slowdown. Our team is already investigating.
Posted Jul 09, 2024 - 10:49 UTC
This incident affected: EU Ireland.