Application slowdown

Incident Report for Rossum

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 07:49 UTC

Monitoring

Situation should be stabilized
Posted Apr 03, 2025 - 07:21 UTC

Identified

Identified the source of slowdown, working towards fix.
Posted Apr 03, 2025 - 07:17 UTC

Investigating

Our application is currently experiencing slowdown when processing incoming documents. Our team is already investigating.
Posted Apr 03, 2025 - 06:44 UTC
This incident affected: EU Frankfurt.