Application slowdown
Incident Report for Rossum
Resolved
We have identified and fixed the root cause, the importing times are back to normal.
Posted Jul 26, 2024 - 13:13 UTC
Investigating
Our application is currently experiencing some slowdown. Our team is already investigating.
Posted Jul 26, 2024 - 13:05 UTC
This incident affected: EU Ireland and US east coast.